IntelliJ IDEA 2017.2升级后mybatis-plugin不能用

IntelliJ IDEA 安装信息

IntelliJ IDEAEclipse的习惯与文化还是存在一些差异性在里面,比如:工作原理、快捷键等。我们先看一下,IDEA一些安装目录。

  • Application的目录:/Applications/IntelliJ IDEA.app
  • 安装插件目录:/Users/chenyuan/Library/Application Support/IntelliJIdea2017.2
  • 偏好设置:/Users/chenyuan/Library/Preferences/IntelliJIdea2017.2
  • 缓存设置:/Users/chenyuan/Library/Caches/IntelliJIdea2017.2

对于每次的升级,多多少少都会产生一些毛病,比如:部分插件兼容问题,其中我非常喜欢的一个插件mybatis-plugin,基本升级后不能用的概率会比较大,而该插件是收费插件。所以每次都要去找破解(不过,现在已经渐渐在往付费转移了,建议大家都用正版软件,也是对软件开发者的尊重),下面就介绍一下mybatis-plugin的破解过程。

了解一下mybatis-plugin插件

  • 从Java代码里往XML里跳转

  • 从XML代码里Java跳转 相互切换十分的方便,为开发带来效率

如何破解mybaits-plugin插件

之前的IntelliJ IDEA的升级的时候,只需要把其中的mybatis_plus.jar替换成破解的包就行了,随着版本的升级,破解包就不那么容易被下载到。

-rw-r--r--  1 chenyuan  staff   716K Aug  9 22:02 httpclient-4.5.1.jar
-rw-r--r--  1 chenyuan  staff   504K Aug  9 22:02 mybatis-generator-core-1.3.2.jar
-rw-r--r--  1 chenyuan  staff   2.0M Aug  9 22:12 mybatis_plus.jar
-rw-r--r--  1 chenyuan  staff   559K Aug  9 22:02 ref.idea.common-1.0.jar
 ~/Library/Application Support/IntelliJIdea2017.2/mybatis_plus/lib 

通过Google的搜索,找到了一个Github的项目,里面就有介绍,感谢作者。 https://github.com/myoss/profile/tree/master/idea/plugin/MybatisPlugin 请查阅Mybatis-Plugin插件学习使用方法.txt里面的内容,将新的class文件重新update到mybatis_plus.jar,然后再去替换jar包,重启IDEA就可以了。

核心代码部分:

jar uvf mybatis_plus.jar com  

通过测试,是OK的。